How to configure openstack_sync

Hi everyone,
i have a question regarding the openstack_sync function.
I installed the newest version of the application through apt on a Ubuntu 18.04 (which worked like a charm).
The documentation references “local settings” to configure the openstack syncs.
Where are those settings stored / supposed to be stored?

I can’t find a description in the docs and can’t find any example file on the system itself.
Wherever i store my configuration, the ralphctl openstack_sync command runs without finding anything or throwing any error messages.

If i can provide any further info, let me know.

Best regards
Matthias

Hi!

Settings are located in /etc/ralph. And here’s the documentation section about OpenStack

I hope that helps.

https://ralph-ng.readthedocs.io/en/stable/installation/installation/

Hi Marcin, thanks for the fast reply.
I’m not sure i completely understand where and how to put the configuration as described in the docs.
I tried adding the configuration to the ralph.conf (and other existing confs) and created an entirely new file called openstack.conf.
Adding it to the existing ralph.conf causes the application to not start up properly.
A newly created openstack.conf seems to be ignored and the sync command runs with no new imports.
I’ll add my console output and config example below.
I think i’m missing an obvious step in the configuration :smiley:

One special constellation i have, is that i only have access to specific projects within openstack - not the whole openstack itself. Similar to OpenStack as a Service… (not my choice :smiley: )
Should Ralph simply import what it gets or could this cause an issue?

root@ralph3:/etc/ralph# ll
total 16
drwxr-xr-x  3 root root 4096 May 17 13:16 ./
drwxr-xr-x 95 root root 4096 May 17 13:02 ../
drwxr-xr-x  2 root root 4096 May 17 13:01 conf.d/
-rw-r--r--  1 root root  135 May 17 13:15 ralph.conf

root@ralph3:/etc/ralph/conf.d# ll
total 24
drwxr-xr-x 2 root root 4096 May 17 13:01 ./
drwxr-xr-x 3 root root 4096 May 17 13:16 ../
-rw-r--r-- 1 root root  819 Apr 14 09:15 cache.conf
-rw-r--r-- 1 root root  167 May 17 13:01 database.conf
-rw-r--r-- 1 root root  242 Apr 14 09:15 gunicorn.conf
-rw-r--r-- 1 root root  325 Apr 14 09:15 redis.conf
root@ralph3:/etc/ralph# ralphctl openstack_sync

        Openstack projects synced

        Synchronization type:   FULL

        New projects:           0
        Modified projects:      0
        Deleted projects:       0
        Total projects:         0

        New instances:          0
        Modified instances:     0
        Deleted instances:      0
        Total instances:        0

        New flavors:            0
        Modified flavors:       0
        Deleted flavors:        0
        Total flavors:          0
OPENSTACK_INSTANCES = [
    {
        'username':     'generic-username-here',
        'password':     'generic-password-here',
        'tenant_name':  'generic-tenant-name-here',
        'version':      '3.0',
        'auth_url':     'https://auth.api.of.our.cloud/v3/',
        'tag':          'someinfo'
    }
]