Dev environment setup issues

I’m trying to set up the ralph development environment to modify the source code.
When trying to pip install the requirements, there are too many dependency issues causing the pip to fail.
I’m performing this on a clean install in Ubuntu 18.04

Is there any way to resolve this or an alternative method of making source code changes and having it reflect on the site?


Hi, I had same issue on Ubuntu 20.04.
First I installed with python3.8 and I had a lot of depencies errors.
Then I have installed python3.6.
I ran the setup script, then I solved version dependencies in openstack.txt
When trying to install mkdocs :
but mkdocs 1.1 depends on Markdown>=3.2.1
In base.txt : Markdown<3.0 # headerid extension removed in 3.0 - see #3313 for details

Is Anyone has already fixed this dependencies?

Try installing a minimal set of requirements.
Mkdocs and stuff are only required for the documentation, not needed for the development.
requirements-base.txt should be sufficient to run ralph.